Ubuntu [SOLVED]: Xvfb + ffmpeg/aconv not working

Ubuntu [SOLVED]: Xvfb + ffmpeg/aconv not working

Home Forums Ubuntu Ubuntu [SOLVED]: Xvfb + ffmpeg/aconv not working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36841

    Anonymous

    QuestionQuestion

    I’m trying to capture screen using xvfb + aconv.
    I”m using docker to run image. I’ve tried almost everything to make it working, different ubuntu images Debian Centos, different images from docker hub.
    My last build is simple ubuntu:trusty(14.04) image + xvfb + avconv

    FROM ubuntu:trusty
    RUN echo "deb http://ppa.launchpad.net/mozillateam/firefox-next/ubuntu trusty main" > /etc/apt/sources.list.d//mozillateam-firefox-next-trusty.list
    RUN apt-key adv --keyserver keyserver.ubuntu.com --recv-keys CE49EC21
    RUN apt-get update
    RUN apt-get install -y firefox xvfb python-pip
    RUN pip install selenium
    RUN mkdir -p /root/selenium_wd_tests
    #ADD sel_wd_new_user.py /root/selenium_wd_tests
    ADD xvfb.init /etc/init.d/xvfb
    RUN chmod +x /etc/init.d/xvfb
    RUN update-rc.d xvfb defaults
    

    I installed avcnov through apt-get
    then I run Xvfb

    Xvfb -ac :99 -screen 0 1280x1024x24
    

    and firefox
    Then I just run

    avconv -f x11grab -r 25 -s 1280x1024 -i :99 -vcodec libx264 -threads 4 $HOME/output.avi
    

    and nothing happens, avconv is stuck it doesn’t starts capturing

    avconv version 9.20-6:9.20-0ubuntu0.14.04.1, Copyright (c) 2000-2014 the Libav developers
      built on Dec  7 2016 21:22:31 with gcc 4.8 (Ubuntu 4.8.4-2ubuntu1~14.04.3)
    [x11grab @ 0x2189c60] device: :99 -> display: :99 x: 0 y: 0 width: 1280 height: 1024
    

    Anybody please any advice, i’ve spent 4 days trying to make it work.
    Thanks.

    #36842

    Anonymous

    Accepted AnswerAnswer

    So the only thing i should know about it all before start that ctrl+z doesn’t brings tasks to background. That was my problem.

    Source: https://stackoverflow.com/questions/47982824/xvfb-ffmpeg-aconv-not-working
    Author: ipauler
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.