Ubuntu [SOLVED]: Makefile:160: recipe for target 'all' failed

Ubuntu [SOLVED]: Makefile:160: recipe for target 'all' failed

Home Forums Ubuntu Ubuntu [SOLVED]: Makefile:160: recipe for target 'all' failed

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36828

    Anonymous

    QuestionQuestion

    Guys am trying to install opencv 3.3.1 on Raspbian stretch Noobs on Pi model B
    I am following this tutorial
    https://www.pyimagesearch.com/2017/09/04/raspbian-stretch-install-opencv-3-python-on-your-raspberry-pi/

    But when i type

    cmake
    -D CMAKE_BUILD_TYPE=RELEASE 
    -D INSTALL_PYTHON_EXAMPLES=ON 
    -D CMAKE_INSTALL_PREFIX=/usr/local 
    -D INSTALL_C_EXAMPLES=OFF 
    -D OPENCV_EXTRA_MODULES_PATH= ~/Opencv_contrib-3.3.1/modules 
    -D BUILD_opencv_python3=yes 
    -D BUILD_EXAMPLES=ON 
    -D WITH_CUDA=OFF.. `
    

    And then i type make -j2

    To get this error

    [  7%] building cxx object 3rsparty/openexr/CMakeFiles/IlmImf.dir/IlmImf/    ImfZipcompressor.cpp.o
    [  7%] linking cxx static library.. /lib/libIlmImf.a
    [  7%] built target IlmImf
    Makefile:160: recipe for target 'all' failed
    make: *** [all] Error 2
    

    What’s the problem?
    And thanks

    #36829

    Anonymous

    Accepted AnswerAnswer

    I found that the problem was in this line

    /home/pi/opencv3.3.1/3rdparty/carotene/src/absdiff.cpp:42:22: fatal error: common.hpp: no such file or directory
     #include "common.hpp"
    

    I ‘ve gone through the directory and opened absdiff.cpp to find #include "common.hpp"
    But no file called common.hpp in the same directory so i copied common.hpp from
    /home/pi/opencv/3rd party/carotene/src/
    Which i cloned using this code
    git clone https://github.com/Itseez/opencv.git opencv

    I don’t know why opencv-3.3.1 doesn’t have it or just an issue during the download…

    Or just re-download opencv-3.3.1 again

    Source: https://stackoverflow.com/questions/47963579/makefile160-recipe-for-target-all-failed
    Author: user9134780
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.