Ubuntu [SOLVED]: 403 error with LAMP and symfony

Ubuntu [SOLVED]: 403 error with LAMP and symfony

Home Forums Ubuntu Ubuntu [SOLVED]: 403 error with LAMP and symfony

Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36839

    Anonymous

    QuestionQuestion

    With a LAMP server running on Ubuntu 16.04, I get the error in the log file defined as in conf :

    [Tue Dec 26 16:56:35.930629 2017] [core:error] [pid 21749] (13)Permission denied: [client 127.0.0.1:43872] AH00035: access to / denied (filesystem path '/home/christophe/public_html') because search permissions are missing on a component of the path
    

    I set my .conf file with the following :

    <VirtualHost *:80>
        ServerName memory.test
        ServerAlias www.memory.test
    
        DocumentRoot /home/christophe/public_html/memory/web
        <Directory /home/christophe/public_html/memory/web>
            AllowOverride All
            Require all granted
            Allow from all
        </Directory>
        ErrorLog /var/log/apache2/memory_error.log
        CustomLog /var/log/apache2/memory_access.log combined
    </VirtualHost>
    

    The access right are set for user christophe:christophe and www-data is part of the group christophe, the mod is 775 but even with the www-data:www-data I get the error.

    The /etc/hosts file contains the line :

     127.0.0.1       memory.test
    

    I seem to not have selinux installed as this solution is given in some other questions. I would not consider myself as a newbee and I succeeded to have many test environments working this way but this linux is a fresh installation and for a while no other website is working on it…

    #36840

    Anonymous

    Accepted AnswerAnswer

    Did you check that you have 0644 in the directory you are trying to serve?, besides, you also give permissions to www-data user to access that directory, note that the folder you are trying to serve is located in your home directory.

    Source: https://stackoverflow.com/questions/47981014/403-error-with-lamp-and-symfony
    Author: bretanac93
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.