Ubuntu-14.04 [SOLVED]: No Booting Option, EFI file missing,

Ubuntu-14.04 [SOLVED]: No Booting Option, EFI file missing,

Home Forums Ubuntu 14.04 Ubuntu-14.04 [SOLVED]: No Booting Option, EFI file missing,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35574

    Anonymous

    QuestionQuestion

    I’m new to ubuntu filesystem

    at first I tried to install ubuntu 16.04 to my flashdrive by following this tutorial http://ubuntuhandbook.org/index.php/2014/11/install-real-ubuntu-os-usb-drive/ using my preinstalled ubuntu14.04 dell leptop

    however after finish install, I couldn’t boot to that new instaled ubuntu from my flashdrive. When I select bootx64.efi file, it just won’t boot.

    using live ubuntu 16, I open gparted (again) and messing with my laptop partition. I change flag of my /dev/sda1 laptop partition (FAT32, labeles EFS, flag boot) to msftdata flag. I did that with purpose so I can see .efi file there and copy to my flashdrive, hopefully it can boot. After I get .efi file, I change the flag of /dev/sda1 back to “boot” again

    however, when I want to boot to my ubuntu14 in my laptop, it just show “No Booting Option”

    Because panic, I start messing more.. using gparted, I formated that /dev/sda1 to fat32 with boot flag again, but I failed to backup whatever inside it before. So that partition is clear (500mb)

    luckly, with live ubuntu16, I still can open ext4 partition and backup all my data from my laptop. But still I desprate want my ubuntu14 on my laptop back.

    I’ve tried using live ubuntu14.04.5 (same version as on my laptop) hope there are “repair option”. but there are none

    I don’t care anymore with ubuntu16 on my flashdrive, I just want my ubuntu14 on my laptop booting back 🙁

    please help..

    #35575

    Anonymous

    Accepted AnswerAnswer

    thx God I’ve found the answer.
    it’s simple,, there are repair boot option, but you have to install it first while using live ubuntu.

    • connect to the Internet

    • open a new Terminal, then type the following commands (press Enter after each line):

      sudo add-apt-repository ppa:yannubuntu/boot-repair
      sudo apt-get update
      sudo apt-get install -y boot-repair && boot-repair
      
    • click the “Recommended repair” button. When repair is finished, note the URL (paste.ubuntu.com/XXXXX) that appeared on a paper

    • reboot the computer, and viola!

    Do not run Boot-Repair unless you have problems booting the computer;
    the expression “if it ain’t broke, don’t fix it” applies to this
    tool.

    This should fix most boot problems. If the repair did not succeed, indicate the URL to people who can help you.

    detail explanation see here

    https://help.ubuntu.com/community/UEFI

    https://help.ubuntu.com/community/Boot-Repair

    Source: https://stackoverflow.com/questions/47650665/no-booting-option-efi-file-missing
    Author: gopalgopel
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.