SSL [SOLVED]: Reinstall rhn-client-tools with non working yum

SSL [SOLVED]: Reinstall rhn-client-tools with non working yum

Home Forums SSL SSL [SOLVED]: Reinstall rhn-client-tools with non working yum

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36764

    Anonymous

    QuestionQuestion

    For every yum command it will return SSL certificate error

    Loaded plugins: fastestmirror, rhnplugin, security
    The SSL certificate failed verification.
    

    My SSL cert if valid.

    I checked rhel site for https://access.redhat.com/solutions/93313 but the problem is i cannot reinstall rhn-client-tools since yum is actually not working and for some other reasons i cannot boot it from DVD/image.

    Any tips on this?

    #36765

    Anonymous

    Accepted AnswerAnswer

    Before trying to reinstall, have you also checked your firewall settings and the time and date setting on your server ?

    If the firewall is not the issue, I would suggest a simpler approach, just by going to RH’s site and downloading the appropriate rhn-client-tools RPM package, copying it to your server and installing it.

    What about the possible dependencies?” I foresee you asking…

      1. Use a different server (or VM) with the same OS version that has access to the internet.
      1. use yum with the download only plugin to only download all the needed dependencies (you must have the yum-plugin-downloadonly package installed beforehand) in a local directory like so:
        yum install --downloadonly --downloaddir=<directory> <package>
      1. Copy the packages downloaded at step #2 to your affected machine and install them using the rpm utility as so: rpm -ivh /path/to/yum/download/dir/*

    Source: https://stackoverflow.com/questions/47885315/reinstall-rhn-client-tools-with-non-working-yum
    Author: AnythingIsFine
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.