Firewall [SOLVED]: Enable port 135 on Azure server

Firewall [SOLVED]: Enable port 135 on Azure server

Home Forums Firewall Firewall [SOLVED]: Enable port 135 on Azure server

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #33359

    Anonymous

    QuestionQuestion

    I have a licensing manager software installed on Azure VM and a client tool tries to connect to it using a DCOM request, which I believe uses port 135. However, I get an ‘access is denied’ error when it tries to establish a connection.

    Port scan

    I did an nmap scan of the server and as you can see in the image above, it says port 135 is filtered. How do I open it? I believe this might be causing the issue.

    Security Group

    As you can see in the image above, I have added port 135 to the inbound rules in the security groups section already. I don’t know if this group is assigned to the VM instance though.

    Firewall

    Firewall is completely disabled on the server. The DCOM services are set for Everyone in DCOM configuration settings. RPC service is running and set to automatic start.

    And finally, here is the actual error I get:

    Error

    I’ve been trying to fix this without success for days, any help is greatly appreciated.

    #33360

    Anonymous

    Accepted AnswerAnswer

    You MUST have a private network connection to communicate over known insecure ports. This is where you must use things like IPSEC VPN, DMVPM, MPLS, SD-WAN.

    Port 135, among MANY others are blocked.

    http://www.dslreports.com/forum/r7673039-Per-homeland-security-qwest-blocking-ports
    https://www.xfinity.com/support/internet/list-of-blocked-ports/

    An Easy solution would be to install Something like ZeroTier on your server and cients, free for up to 100 endpoints.

    Source: https://serverfault.com/questions/883040/enable-port-135-on-azure-server
    Author: Jacob Evans
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.