Dual-Boot [SOLVED]: Ubuntu on Macbook Pro 1,1

Dual-Boot [SOLVED]: Ubuntu on Macbook Pro 1,1

Home Forums Dual Boot Dual-Boot [SOLVED]: Ubuntu on Macbook Pro 1,1

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #34844

    Anonymous

    QuestionQuestion

    I’ve been looking around for a way to install Ubuntu on my Macbook Pro 1,1 but haven’t been able to find a solution. The closest I’ve found is here, but 32-bit EFI images are no longer available for Ubuntu.

    I’ve found some instructions for 32-bit EFI firmwares, but all of these seem to be for 64-bit machines. The original Macbook Pro has a 32-bit processor. The system specs are as follows:

    • Model Name: MacBook Pro 15″
    • Model Identifier: MacBookPro1,1
    • Processor Name: Intel Core Duo
    • Processor Speed: 2 GHz
    • Number of Processors: 1
    • Total Number Of Cores: 2
    • L2 Cache (per processor): 2 MB
    • Memory: 2 GB
    • Bus Speed: 667 MHz
    • Boot ROM Version: MBP11.0055.B08
    • SMC Version:
      1.2f10

    The system barely squeaks by the minimum requirements for Ubuntu, but I was planning on replacing Unity with i3 anyway. As such, I wouldn’t mind installing the Server edition of Ubuntu if necessary. I would like to keep my OSX partition. It has a 100 GB hard drive, and I’ve shrunk the OSX partition down to about 65 GB.

    I’ve yet to find an i386 image that has allowed me to boot via EFI. Should I give up, or is there a solution I haven’t found?

    #34845

    Anonymous

    Accepted AnswerAnswer

    After a lot of searching, I was finally able to get Ubuntu Server to install. If anyone happens to have the same problem, I had to:

    1. Follow the instructions here to prepare a 32-bit Ubuntu Server 17.10 image with EFI.
    2. Boot into the EFI installer. Using rEFInd, the EFI version was the only option, but double check to be sure.
    3. If you get a CD-ROM could not be mounted error in the installer, follow this solution. With Ubuntu Server, I had to execute a shell via the installer instead of pressing alt+f1.
    4. The “Configure the package manager” step of the installer would briefly flash a progress bar and then go back to the main installation menu for me. To fix this, here’s yet another askubuntu solution.
    5. The installation should proceed smoothly from there.
    6. Booting from GRUB kept hanging at parts. There seems to be a problem with the Ubuntu firewire driver. To fix this, edit the Ubuntu grub option with e and add this line to the end: blacklist=firewire_ohci. I’m not sure if this disables firewire on the system or not, as I have no devices to test it with
    7. The system won’t boot with the AMD card. Change the line in the grub entry that ends with ro by adding nomodeset to the end
    8. Make the changes in GRUB permanent, first by opening /etc/default/grub and changing the line GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="nomodeset". Run sudo update-grub after saving the changes.
    9. Add the line blacklist firewire_ohci to /etc/modprobe.d/blacklist.conf

    I haven’t checked to see if all of the hardware is functioning correctly yet, but I at least have a bootable system now.

    I pulled the information about configuring grub from here and here.

    Source: https://askubuntu.com/questions/982280/ubuntu-on-macbook-pro-1-1
    Author: Elurchin
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.