Dual-Boot [SOLVED]: (Non OS) NTFS file system locked, tried chmod, FSTAB looks fine, 'read only file system'

Dual-Boot [SOLVED]: (Non OS) NTFS file system locked, tried chmod, FSTAB looks fine, 'read only file system'

Home Forums Dual Boot Dual-Boot [SOLVED]: (Non OS) NTFS file system locked, tried chmod, FSTAB looks fine, 'read only file system'

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35517

    Anonymous

    QuestionQuestion

    I know there are a ton of similar threads but I’ve tried most of the suggestions and still haven’t solved this.
    I have an NTFS drive which has WinXP on it but I’ve not booted to it in ages and since building a new system and installing 17.10 on a fresh drive, haven’t even got this drive recognised as bootable in grub. When I first installed the system it was fine: I edited FSTAB to mount it in a specific place with certain permissions and it was fine. Current FSTAB entry is:

    UUID=8E3CDEC53CDEA80B   /media/SamsungA ntfs-3g defaults,locale=en_US.UTF-8,user,uid=1000,gid=1000,umask=0000   0   0
    

    Right click, properties, permissions: owner: me. access: rw. group: me, access: rw. others: rw. (I think that’s 777?). BUT: all folders have padlock icons in thunar and trying to chown files/folders to 775 or 777 per instructions gives “file system mounted as read only” in terminal.

    I suspect therefore the problem’s in FSTAB? I previously had:

    UUID=8E3CDEC53CDEA80B   /media/SamsungA ntfs-3g defaults,locale=en_US.UTF-8,async,big_writes    0   0
    

    Though since I changed to the first entry (in order to speed up access time I believe) it WAS working fine, until some point recently.

    Full disclosure, I dual boot to windows 10, but on a different partition (or the same drive as I boot to for linux, neither of which is the problem NTFS drive). Could the win10 install have changed fastboot settings? I’ve seen reference to this but it all appears to relate to the booting windows drive, which this isn’t.

    Thanks in advance!

    p.s. ntfs-3g installed. ntfs config tool installed & enabled for this drive & the win10 booter. I tried a umount/mount suggestion but it didn’t work, and am I right in thinking I should solve this in fstab so it mounts properly on boot rather than once in the file system?

    #35518

    Anonymous

    Accepted AnswerAnswer

    One possible cause:

    The file system is marked as dirty; meaning that it was removed from a system that was hibernated (windows fast start is a hibernation). If the drive was not connected to the system when it was unhibernated the dirty flag wouldn’t be removed.

    Windows will self-repair some minor issues such as this. Be sure Windows’ Fast Start is turned off, some updates will turn it on. Boot Windows 10 twice with the drive connected. Then eject the drive before shutting down Windows.

    Source: https://askubuntu.com/questions/984578/non-os-ntfs-file-system-locked-tried-chmod-fstab-looks-fine-read-only-file
    Author: ravery
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.