Dual-Boot [SOLVED]: BIOS detects HDD but doesn't boot

Dual-Boot [SOLVED]: BIOS detects HDD but doesn't boot

Home Forums Dual Boot Dual-Boot [SOLVED]: BIOS detects HDD but doesn't boot

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #34366

    Anonymous

    QuestionQuestion

    I have a problem and this isn’t really my area and am not able to find a good solution.

    Basically I have two Hard Disks

    • 500 G
    • 1000 G

    In the 500 G HDD > I have windows running

    In the 1000 G HDD > I have Ubuntu running

    A couple of days back, due to high voltage my SMPS sparked out. I took it to the service center and they changed my SMPS and updated BIOS.

    From then on, BIOS doesn’t boot into Ubuntu (1000 G HDD) and directly boots into WINDOWS (500 G HDD).

    So far:

    • The 1000 G HDD is detected by the BIOS. I can see it in the BIOS settings. I can change the boot order between the TWO HDDs

    • Using F10 I tried to boot from the 1000 G HDD and instead got a PXE error. BIOS was not able to boot from 1000G and have tried to ‘Boot from Network’ resulting in the error. I Disabled the ‘Boot from Network’ option.

    • I even disconnected 500 G HDD and tried using only the 1000 G. It simply said “Reboot and Select proper Boot device”

    • When I boot into WINDOWS, under Disk Management, I can see that the 1000 G Hard Disk is in a Good State

    • Finally I borrowed a USB with Ubuntu and booted into it. It provided the option to TRY UBUNTU without actually installing it. I used that option – logged in – and was able to see all my DATA in the 1000 G HDD intact

    • I didn’t partition my 1000 G HDD when I installed Ubuntu – so all my data lies in the single partition (nearly 400 G of DATA). Hence I’m not open for Re-installing the OS (And I also think it isn’t needed).

    It’d be of great help if someone can point me in the correct direction through which I can boot into UBUNTU without losing my DATA.

    #34367

    Anonymous

    Accepted AnswerAnswer

    I found out the issue.

    I tried boot-repair but it threw

    GPT detected. Please create a BIOS-Boot partition

    I searched again and read through a lot. Every discussion eventually ended up with Legacy / UEFI boot methods.

    Finally, I saw that under the BIOS setting – under Boot Menu – UEFI Boot option was disabled. I enabled it again and it went through

    Source: https://askubuntu.com/questions/976770/bios-detects-hdd-but-doesnt-boot
    Author: Krishnakumar
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.