Drivers [SOLVED]: Ubuntu 14.04: How do I disable Realtek RTL8192E/RTL8192SE wifi driver?

Drivers [SOLVED]: Ubuntu 14.04: How do I disable Realtek RTL8192E/RTL8192SE wifi driver?

Home Forums Drivers Drivers [SOLVED]: Ubuntu 14.04: How do I disable Realtek RTL8192E/RTL8192SE wifi driver?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35480

    Anonymous

    QuestionQuestion

    How do I disable my Realtek wifi driver? It makes my laptop freeze when connected. To work around the problem, I got a USB wifi adapter. Problem is, the Realtek driver still connects to the network and I have to manually disconnect it. I tried to blacklist it, but I obviously didn’t do it right. Here is a screenshot of my network connections (the Realtek and the wifi adaptor are both higlhlighted in yellow):

    Screenshot

    My specs are also listed here: http://paste.ubuntu.com/26050614/

    I’m a newbie and confused!! Your help will be greatly appreciated on this one! Thanks!!

    #35481

    Anonymous

    Accepted AnswerAnswer

    Thanks everybody for all your help. I just learned a whole bunch that I wasn’t aware of by reading your posts.

    The answer for me was to identify and blacklist the offending module which it turns out was r8192e_pci and not other ones I had previously added to the blacklist.conf file (the hardest part for me in the end was to properly identify the module that I didn’t want loading).

    Even though it has rtllib as a dependency, doing ‘blacklist r8192e_pci’ appears to be enough to stop it from loading.

    I should add that post #14 from Chili555 also helped me figure things out.
    https://ubuntuforums.org/showthread.php?t=1826243&page=2

    Source: https://askubuntu.com/questions/983290/ubuntu-14-04-how-do-i-disable-realtek-rtl8192e-rtl8192se-wifi-driver
    Author: Spartina
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.