Drivers [SOLVED]: SD-card reader suddenly stopped recognizing cards

Drivers [SOLVED]: SD-card reader suddenly stopped recognizing cards

Home Forums Drivers Drivers [SOLVED]: SD-card reader suddenly stopped recognizing cards

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35483

    Anonymous

    QuestionQuestion

    Recently my sd-card reader stopped working.

    The weird part: 5 minutes earlier etcher successfully wrote an image to an sd-card.
    After wanting to write another imagefile, no sd-cards could get mounted/unmounted/recognized anymore.

    The device refusing to work properly:

    #$ sudo lspci -v
      ...
    03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
        Subsystem: Dell RTS525A PCI Express Card Reader
        Flags: bus master, fast devsel, latency 0, IRQ 129
        Memory at dd100000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [80] Power Management version 3
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [b0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Device Serial Number [xx-xx-xx-xx-xx-xx-xx-xx-xx]
        Capabilities: [158] Latency Tolerance Reporting
        Capabilities: [160] L1 PM Substates
        Kernel driver in use: rtsx_pci
        Kernel modules: rtsx_pci
      ...
    

    Since the device was working like a litteral 5 minutes before, I’m assuming an error
    in either the driver/module or an unremoved device lock which I can’t find.

    There are several things I’ve tried to fix it and it failed:

    • Turning computer off and on again
    • Since the sd-cards used were micro sd-card with adapter, several adapters were tried
    • Several sd-cards were tried (in case the card itself broke)
    • An online suggestion of reinstalling udisks2
    • An online suggestion of sudo apt-get install --reinstall udev*
    • Using a LiveCD on a usb-drive
    • Using another usb sd-card reader

    More information:

    I’m currently running Linux Mint 18 with Xfce desktop environment on my Dell Precision 5510

      Linux kernel:
        4.4.0-103-generic 
      Version:
        #126-Ubuntu SMP Mon Dec 4 16:23:28 UTC 2017 
    

    The running modules which relate to the sd-card reader are:

    #$ lsmod
    Module                  Size  Used by
      ...
    rtsx_pci_ms            20480  0
    memstick               20480  1 rtsx_pci_ms
    rtsx_pci_sdmmc         24576  0
    rtsx_pci               53248  2 rtsx_pci_ms,rtsx_pci_sdmmc
      ...
    

    EDIT:

    • Using an other sd-card reader (via usb) worked after all, I guess I shouldn’t conclude something, if it is not working with the cheapest of hardware.

    #35484

    Anonymous

    Accepted AnswerAnswer

    Own Answer:

    Using an external sd-card reader worked after all. The internal SD-card reader of my machine just broke, which hasn’t anything to do with any config or software.

    Source: https://askubuntu.com/questions/984342/sd-card-reader-suddenly-stopped-recognizing-cards
    Author: Mitms
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.