Drivers [SOLVED]: Intel Dual Band Wireless-AC 7260 with Ubuntu 16.04.3 LTS

Drivers [SOLVED]: Intel Dual Band Wireless-AC 7260 with Ubuntu 16.04.3 LTS

Home Forums Drivers Drivers [SOLVED]: Intel Dual Band Wireless-AC 7260 with Ubuntu 16.04.3 LTS

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36917

    Anonymous

    QuestionQuestion

    I’m having a hard time getting my Intel Dual Band Wireless-AC 7260 to work with my fresh installation of Ubuntu 16.04.3. There are similar questions to this, but all of the ones that I could find are dated. Currently, its not even showing any networks to connect to.

    Here is some output that other posts (e.g. this one) led me to believe would be useful for helping solve this problem:

    seth@desktop$ lspci -knn | grep Net -A2
    04:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev bb)
        Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:4070]
        Kernel driver in use: iwlwifi
    
    seth@desktop:~$ uname -a
    Linux desktop 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    
    seth@desktop:~$ ls /lib/firmware/
    3com                         htc_7010.fw              iwlwifi-8000C-21.ucode         rsi_91x.fw
    4.10.0-28-generic            htc_9271.fw              iwlwifi-8000C-27.ucode         rt2561.bin
    4.10.0-42-generic            i2400m-fw-usb-1.4.sbcf   iwlwifi-8000C-31.ucode         rt2561s.bin
    a300_pfp.fw                  i2400m-fw-usb-1.5.sbcf   iwlwifi-8265-21.ucode          rt2661.bin
    a300_pm4.fw                  i6050-fw-usb-1.5.sbcf    iwlwifi-8265-22.ucode          rt2860.bin
    acenic                       i915                     iwlwifi-8265-27.ucode          rt2870.bin
    adaptec                      intel                    iwlwifi-8265-31.ucode          rt3070.bin
    advansys                     intel-ucode              kaweth                         rt3090.bin
    agere_ap_fw.bin              ipw2100-1.3.fw           keyspan                        rt3290.bin
    agere_sta_fw.bin             ipw2100-1.3-i.fw         keyspan_pda                    rt73.bin
    amdgpu                       ipw2100-1.3-p.fw         korg                           RTL8192E
    ar3k                         ipw2200-bss.fw           lbtf_usb.bin                   rtl_bt
    ar5523.bin                   ipw2200-ibss.fw          lgs8g75.fw                     rtl_nic
    as102_data1_st.hex           ipw2200-sniffer.fw       libertas                       rtlwifi
    as102_data2_st.hex           isci                     liquidio                       s2250.fw
    asihpi                       iwlwifi-1000-5.ucode     Makefile                       s2250_loader.fw
    ath10k                       iwlwifi-100-5.ucode      matrox                         s5p-mfc.fw
    ath3k-1.fw                   iwlwifi-105-6.ucode      mellanox                       s5p-mfc-v6.fw
    ath6k                        iwlwifi-135-6.ucode      moxa                           s5p-mfc-v6-v2.fw
    ath9k_htc                    iwlwifi-2000-6.ucode     mrvl                           s5p-mfc-v7.fw
    atmel                        iwlwifi-2030-6.ucode     mt7601u.bin                    s5p-mfc-v8.fw
    atmel_at76c504_2958.bin      iwlwifi-3160-10.ucode    mt7650.bin                     sb16
    atmel_at76c504a_2958.bin     iwlwifi-3160-12.ucode    mts_cdma.fw                    scripts
    atmsar11.fw                  iwlwifi-3160-13.ucode    mts_edge.fw                    sdd_sagrad_1091_1098.bin
    atusb                        iwlwifi-3160-16.ucode    mts_gsm.fw                     slicoss
    av7110                       iwlwifi-3160-17.ucode    mts_mt9234mu.fw                sun
    bnx2x                        iwlwifi-3160-7.ucode     mts_mt9234zba.fw               tehuti
    brcm                         iwlwifi-3160-8.ucode     mwl8k                          ti_3410.fw
    carl9170-1.fw                iwlwifi-3160-9.ucode     mwlwifi                        ti_5052.fw
    carl9170fw                   iwlwifi-3168-21.ucode    myri10ge_eth_big_z8e.dat       ti-connectivity
    cavium                       iwlwifi-3168-22.ucode    myri10ge_ethp_big_z8e.dat      tigon
    cbfw-3.2.1.1.bin             iwlwifi-3168-27.ucode    myri10ge_ethp_z8e.dat          ti-keystone
    cbfw-3.2.3.0.bin             iwlwifi-3168-29.ucode    myri10ge_eth_z8e.dat           tlg2300_firmware.bin
    cbfw-3.2.5.1.bin             iwlwifi-3945-2.ucode     myri10ge_rss_eth_big_z8e.dat   ttusb-budget
    cis                          iwlwifi-4965-2.ucode     myri10ge_rss_ethp_big_z8e.dat  ueagle-atm
    configure                    iwlwifi-5000-5.ucode     myri10ge_rss_ethp_z8e.dat      usbdux
    cpia2                        iwlwifi-5150-2.ucode     myri10ge_rss_eth_z8e.dat       usbduxfast_firmware.bin
    ct2fw-3.2.1.1.bin            iwlwifi-6000-4.ucode     netronome                      usbdux_firmware.bin
    ct2fw-3.2.3.0.bin            iwlwifi-6000g2a-5.ucode  NPE-B                          usbduxsigma_firmware.bin
    ct2fw-3.2.5.1.bin            iwlwifi-6000g2a-6.ucode  NPE-C                          v4l-cx231xx-avcore-01.fw
    ctefx.bin                    iwlwifi-6000g2b-6.ucode  nvidia                         v4l-cx23418-apu.fw
    ctfw-3.2.1.1.bin             iwlwifi-6050-5.ucode     ositech                        v4l-cx23418-cpu.fw
    ctfw-3.2.3.0.bin             iwlwifi-7260-10.ucode    phanfw.bin                     v4l-cx23418-dig.fw
    ctfw-3.2.5.1.bin             iwlwifi-7260-12.ucode    qat_895xcc.bin                 v4l-cx2341x-dec.fw
    ctspeq.bin                   iwlwifi-7260-13.ucode    qat_895xcc_mmp.bin             v4l-cx2341x-enc.fw
    cxgb3                        iwlwifi-7260-14.ucode    qat_c3xxx.bin                  v4l-cx2341x-init.mpg
    cxgb4                        iwlwifi-7260-16.ucode    qat_c3xxx_mmp.bin              v4l-cx23885-avcore-01.fw
    dsp56k                       iwlwifi-7260-17.ucode    qat_c62x.bin                   v4l-cx25840.fw
    dvb-fe-xc4000-1.4.1.fw       iwlwifi-7260-7.ucode     qat_c62x_mmp.bin               v4l-pvrusb2-24xxx-01.fw
    dvb-fe-xc5000-1.6.114.fw     iwlwifi-7260-8.ucode     qat_mmp.bin                    v4l-pvrusb2-29xxx-01.fw
    dvb-fe-xc5000c-4.1.30.7.fw   iwlwifi-7260-9.ucode     qca                            vicam
    dvb-usb-dib0700-1.20.fw      iwlwifi-7265-10.ucode    qcom                           vntwusb.fw
    dvb-usb-it9135-01.fw         iwlwifi-7265-12.ucode    qed                            vpu_d.bin
    dvb-usb-it9135-02.fw         iwlwifi-7265-13.ucode    ql2100_fw.bin                  vpu_p.bin
    dvb-usb-terratec-h5-drxk.fw  iwlwifi-7265-16.ucode    ql2200_fw.bin                  vxge
    ea                           iwlwifi-7265-17.ucode    ql2300_fw.bin                  WHENCE.ubuntu
    edgeport                     iwlwifi-7265-8.ucode     ql2322_fw.bin                  whiteheat.fw
    emi26                        iwlwifi-7265-9.ucode     ql2400_fw.bin                  whiteheat_loader.fw
    emi62                        iwlwifi-7265D-10.ucode   ql2500_fw.bin                  wil6210.brd
    ene-ub6250                   iwlwifi-7265D-12.ucode   r128                           wil6210.fw
    ess                          iwlwifi-7265D-13.ucode   r8a779x_usb3_v1.dlmem          wsm_22.bin
    f2255usb.bin                 iwlwifi-7265D-16.ucode   r8a779x_usb3_v2.dlmem          yam
    go7007                       iwlwifi-7265D-17.ucode   r8a779x_usb3_v3.dlmem          yamaha
    GPL-3                        iwlwifi-7265D-21.ucode   radeon                         zd1201-ap.fw
    hfi1_dc8051.fw               iwlwifi-7265D-22.ucode   README                         zd1201.fw
    hfi1_fabric.fw               iwlwifi-7265D-27.ucode   rp2.fw                         zd1211
    hfi1_pcie.fw                 iwlwifi-7265D-29.ucode   RS9113_AP_BT_DUAL_MODE.rps
    hfi1_sbus.fw                 iwlwifi-8000C-13.ucode   RS9113_WLAN_BT_DUAL_MODE.rps
    hp                           iwlwifi-8000C-16.ucode   RS9113_WLAN_QSPI.rps
    

    The information on this Intel site leads me to believe that the iwlwifi-7260-14.ucode should be making this work, but its not.

    Edit: Outputs of more commands, as requested:

    seth@desktop:~$ rfkill list all
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    seth@desktop:~$ dmesg | grep iwl
    [    1.828348] iwlwifi 0000:04:00.0: enabling device (0000 -> 0002)
    [    1.844321] iwlwifi 0000:04:00.0: loaded firmware version 17.608620.0 op_mode iwlmvm
    [    1.856324] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
    [    1.857417] iwlwifi 0000:04:00.0: L1 Disabled - LTR Enabled
    [    1.857637] iwlwifi 0000:04:00.0: L1 Disabled - LTR Enabled
    [    2.068873] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
    [    2.069769] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
    [    2.228905] iwlwifi 0000:04:00.0: L1 Disabled - LTR Enabled
    [    2.229125] iwlwifi 0000:04:00.0: L1 Disabled - LTR Enabled
    [    2.439776] iwlwifi 0000:04:00.0: L1 Disabled - LTR Enabled
    [    2.439995] iwlwifi 0000:04:00.0: L1 Disabled - LTR Enabled
    

    **edit 2: ** and some more…

    seth@desktop:~$ sudo iwlist scan
    enp2s0    Interface doesn't support scanning.
    
    lo        Interface doesn't support scanning.
    
    wlp4s0    Interface doesn't support scanning : Device or resource busy
    
    seth@desktop:~$ iwconfig
    enp2s0    no wireless extensions.
    
    lo        no wireless extensions.
    
    wlp4s0    IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
    

    Edit 3: yet more…

    seth@desktop:~$ dmesg | grep wlp
    [    2.069769] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
    [    2.226853] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
    [    2.462231] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
    [    2.571468] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
    

    #36918

    Anonymous

    Accepted AnswerAnswer

    From our discussion in chat, and seeing nothing else incorrect, it appears that in connecting the PCIe mini-to-PCIe adapter, the antenna wire was either not connected or wiggled loose. You opened the computer and connected the antenna firmly and the wireless is working!

    Source: https://askubuntu.com/questions/990936/intel-dual-band-wireless-ac-7260-with-ubuntu-16-04-3-lts
    Author: chili555
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.