Drivers [SOLVED]: How to load iwlwifi driver?

Drivers [SOLVED]: How to load iwlwifi driver?

Home Forums Drivers Drivers [SOLVED]: How to load iwlwifi driver?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36915

    Anonymous

    QuestionQuestion

    My Linux system can’t detect my wireless driver, so I have to load it manually.
    I know what my driver is and tired this method:

    Installation of the firmware is simply:

     % cp iwlwifi-7260-14.ucode /lib/firmware
    

    You can now load the driver!

    So I have successively copied the driver in the proper location /lib/firmware but I don’t know what is meant by TO LOAD THE DRIVER. I thought that simply copying the driver into /lib/firmware would do the trick but NO it should be loaded into the kernel as is written in the instruction.

    But how am I supposed to load this driver, what should I do to load it?


    Here is what I did:

    root@gNewSense:/home/georgi# modprobe -r iwlwifi
    root@gNewSense:/home/georgi# modprobe iwlwifi
    root@gNewSense:/home/georgi# lsmod | grep iwl
    iwlwifi               162535  0 
    mac80211              192806  1 iwlwifi
    cfg80211              137243  2 mac80211,iwlwifi
    root@gNewSense:/home/georgi# lspci -nnk | grep 0280 -A3
    08:00.0 Network controller [0280]: Intel Corporation Device [8086:08b2] (rev 83)
        Subsystem: Intel Corporation Device [8086:c270]
    09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 10)
        Subsystem: Lenovo Device [17aa:380d]
    root@gNewSense:/home/georgi# dmesg | grep iwl
    root@gNewSense:/home/georgi# rfkill list all
    0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
    2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    

    Hopefully there is some clue in this output!

    Excuse me for not mentioning it at the beginning but the GNU system that is gNewSense (it is Debian based) not Ubuntu. Anyway after reboot gives me this:

    root@gNewSense:~# dmesg | grep iwl
    root@gNewSense:~# uname -r
    3.2.0-4gnewsense1-amd64
    

    Also the official driver info in gNewSense pages is:
    it isn’t work with a free driver

    #36916

    Anonymous

    Accepted AnswerAnswer

    You can load the driver with:

    sudo modprobe iwlwifi
    

    The driver iwlwifi and, indeed, the required firmware are included by default in all recent Ubuntu versions. If it is not loaded, something else is wrong.

    Is yours really an iwlwifi device? Check:

    lspci -nnk | grep 0280 -A3
    

    Is the switch or key combination set to enable or disable the wireless? Check:

    rfkill list all
    

    Are there any clues in the log?

    dmesg | grep iwl
    

    After we find out more, I will edit this question to add additional troubleshooting steps.

    Source: https://askubuntu.com/questions/990363/how-to-load-iwlwifi-driver
    Author: chili555
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.