Drivers [SOLVED]: Games by Feral renders everything as black, other games work just fine

Drivers [SOLVED]: Games by Feral renders everything as black, other games work just fine

Home Forums Drivers Drivers [SOLVED]: Games by Feral renders everything as black, other games work just fine

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36541

    Anonymous

    QuestionQuestion

    EDIT:
    This is how the main menu of Life is Strange looks like

    My hardware:
    CPU: AMD FX-6300
    GPU: AMD R9 270X 2GB

    I’ve got a peculiar issue with games by Feral such as Life is Strange and Shadow of Mordor: all 3D objects are rendered as pitch black, no matter what it is

    The games used to work fine under Lubuntu 16.10 with Mesa 17.0.2, but then I upgraded to Lubuntu 17.10 (preserving /home) and now the games simply render as black

    I have my / and /home in separate physical drives, so when I upgrade I simply erase / partition and mount my old /home

    So far, I’ve tried these, none of which worked:

    1. Update mesa to 17.2.4
    2. Delete steam shader cache
    3. Delete .local/share/feral-interactive folder
    4. Delete .cache/mesa
    5. Revert to Lubuntu 16.04 with Mesa 17.0.7 (without updating anything else)
    6. Revert to Lubuntu 16.04, this time I don’t use my old /home at all and create a new /home partition, then download a new copy of Life is Strange with a new copy of Steam.

    As title says, this issue only affects Feral games, all other games such as:

    • Crusader Kings II
    • Stellaris
    • Dungeons 2
    • Ploy Bridge

    Are rendered correctly. Is there anything else I can try?

    #36542

    Anonymous

    Accepted AnswerAnswer

    Based on the hardware that you have here are some suggestions that might or might not help (Remember I have Nvidia and Intel, basically the opposite of you), but it’s worth a shot at the expense of creating issues since some of the suggestions are in development:

    Check out the notes for each game. For example if you look at Shadow of Mordor you will see this:

    enter image description here

    They mention Catalyst there because they are still talking about 14.04 and older version that used Catalyst instead of Mesa only at the time, but with the modern changes to Mesa for AMD, and the fact that you mentioned it was working correctly on 16.10, it means that things have improved a lot. Still, the note they leave is not to be taken lightly (Meaning that it might work, or might not). So with that said, here are the steps you could take if you want to.

    Install a bleeding edge Mesa driver.

    Add this PPA to your Ubuntu version (Oibaf’s PPA):

    sudo add-apt-repository ppa:oibaf/graphics-drivers
    

    It uses the latest Mesa driver from Git, meaning you will get the latest update to it, along with getting a bunch of updates every day but also a bunch of errors. So it’s risky.

    Install the latest Stable version of Mesa

    Safer than installing the latest bleeding edge one and you are able to test out the big changes applied to it. Coming from the 17.0.2 you have to the latest 17.2.4 means a lot of important performance enhancements. Get it by installing the Swat PPA:

    sudo add-apt-repository ppa:ubuntu-x-swat/updates
    

    After selecting either the Bleeding Edge one or the Stable one, you need to do a sudo apt update && sudo apt upgrade to upgrade your current Mesa to the latest one in said PPA. The Stable one was updated by the looks of it because Feral was asking for an updated Mesa version to test their games in. At the end you are ending up with Mesa 17.2 which brought tons of improvements for Ati graphics card.

    Source: https://askubuntu.com/questions/987284/games-by-feral-renders-everything-as-black-other-games-work-just-fine
    Author: Luis Alvarado
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.