Drivers [SOLVED]: Dependencies unsatisfied for offline Broadcom installation

Drivers [SOLVED]: Dependencies unsatisfied for offline Broadcom installation

Home Forums Drivers Drivers [SOLVED]: Dependencies unsatisfied for offline Broadcom installation

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36074

    Anonymous

    QuestionQuestion

    I just installed Ubuntu 17.1 on my Dell Precision M6500 (so the laptop is vintage 2009-2010), alongside Windows 7. When in Windows, wifi works fine (and the LED is ON, just above keyboard). When in Ubuntu, no wifi, wifi light is off, and if I go to Ubuntu Settings, the wifi page indicates that there is no wifi adapter. If I then try the lspci command, I get this for the Broadcom devices:

    dell-M6500:~$ lspci -nnk |grep -iA3 broadcom
    09:00.0 Ethernet controller [0200]: Broadcom Limited NetXtreme BCM5761e Gigabit Ethernet PCIe [14e4:1680] (rev 10)
        Subsystem: Dell NetXtreme BCM5761e Gigabit Ethernet PCIe [1028:02ef]
        Kernel driver in use: tg3
        Kernel modules: tg3
    0c:00.0 Network controller [0280]: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
        Subsystem: Dell Wireless 1510 Wireless-N WLAN Mini-Card [1028:000d]
        Kernel driver in use: b43-pci-bridge
        Kernel modules: ssb
    

    If I then follow the instructions at How to install Broadcom wireless drivers offline?, I get this:

    dell-M6500:~$ ls
    bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu3_amd64.deb  Music
    Desktop                                                    Pictures
    dkms_2.3-3ubuntu3_all.deb                                  Public
    Documents                                                  Templates
    Downloads                                                  Videos
    examples.desktop
    dell-M6500:~$ sudo dpkg -i *.deb
    [sudo] password for ...: 
    Selecting previously unselected package bcmwl-kernel-source.
    (Reading database ... 126010 files and directories currently installed.)
    Preparing to unpack bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu3_amd64.deb ...
    Unpacking bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu3) ...
    Selecting previously unselected package dkms.
    Preparing to unpack dkms_2.3-3ubuntu3_all.deb ...
    Unpacking dkms (2.3-3ubuntu3) ...
    dpkg: dependency problems prevent configuration of bcmwl-kernel-source:
     bcmwl-kernel-source depends on linux-libc-dev; however:
      Package linux-libc-dev is not installed.
     bcmwl-kernel-source depends on libc6-dev; however:
      Package libc6-dev is not installed.
    
    dpkg: error processing package bcmwl-kernel-source (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of dkms:
     dkms depends on gcc; however:
      Package gcc is not installed.
     dkms depends on make | build-essential | dpkg-dev; however:
      Package make is not installed.
      Package build-essential is not installed.
      Package dpkg-dev is not installed.
    
    dpkg: error processing package dkms (--install):
     dependency problems - leaving unconfigured
    Processing triggers for man-db (2.7.6.1-2) ...
    Errors were encountered while processing:
     bcmwl-kernel-source
     dkms
    

    This laptop does not support UEFI boot so there is no Secure Boot option to turn off (I also looked in BIOS and could not find anything related to secure boot). BIOS is latest (A10).

    Any ideas of how to make wifi work?

    #36075

    Anonymous

    Accepted AnswerAnswer

    Installation of the Broadcom driver failed because several of the package dependencies are not installed and, in at least one case, the dependencies of the dependency!

    You have two options. First is the one minute option. Beg or borrow an ethernet connection from a friend or relative. Bribe them with a six-pack of their favorite beverage if needed. Then open a terminal and do:

    sudo apt update
    sudo apt install -f bcmwl-kernel-source
    

    Done!

    The second alternative, often the one week option, is to go here: https://packages.ubuntu.com/ Select artful, the code name for Ubuntu 17.10. Find the missing packages, in your case, linux-libc-dev, make, build-essential and dpkg-dev. Be certain to also download the dependencies of the dependencies. For instance, as you see by the red dot, make depends on libc6.

    enter image description here

    You can check to see if it is already installed with:

    sudo dpkg -s libc6
    

    On my system, it is already installed, so I see:

    Package: libc6
    Status: install ok installed
    

    Be sure to download either the 32- or 64-bit version as needed. Find out with the terminal command:

    arch
    

    If it returns x86_64, then you need the 64-bit versions of these packages, also known as amd64.

    Transfer all these on a USB key or similar and install them all as you did previously:

    sudo dpkg -i *.deb
    

    If there are still more missing dependencies, go back and try again.

    I am not quite sure how you got Ubuntu installed without the usual packages linux-libc-dev, make, build-essential and dpkg-dev, but this process should correct the install.

    Source: https://askubuntu.com/questions/986827/dependencies-unsatisfied-for-offline-broadcom-installation
    Author: chili555
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.