Apache2 [SOLVED]: Apache2 Not Responding: Bitnami Magento Install (Legacy)

Apache2 [SOLVED]: Apache2 Not Responding: Bitnami Magento Install (Legacy)

Home Forums Apache2 Apache2 [SOLVED]: Apache2 Not Responding: Bitnami Magento Install (Legacy)

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36901

    Anonymous

    QuestionQuestion

    For reasons too insane to even go into, I am attempting to install using the Bitnami Magento 1.9.2.4 image on a fresh Amazon AWS/Lightsail Ubuntu 16.04 instance (2gbs to avoid complaints and be sure I don’t run into anything unnecessary).

    I think this is really more of an Apache question. After I finish the install (success), I can’t get the server to respond via the instance IP address at the default port (8080).

    Regarding the old Bitnami Image, you can get (or wget) that Magento 1.9.2.4 image still, it’s over here:

    wget "https://downloads.bitnami.com/files/stacks/magento/1.9.2.4-3/bitnami-magento-1.9.2.4-3-linux-x64-installer.run" 
    

    So for the sake of anyone who’s trying to work through the whole process, once you pull the above down to your instance you need to chmod the above file to 755. This assumes you are in the directory with your download:

    chmod 755 bitnami-magento-1.9.2.4-3-linux-x64-installer.run
    

    Then run it using it’s full path, like:

    /home/ubuntu/bitnami-magento-1.9.2.4-3-linux-x64-installer.run
    

    So the install is going to ask a bunch of questions, for anyone keeping track my answers were all yes (ie. yes to Git, PhpMyAdmin, Beetailer… whatever that is).

    Then I created an admin user / password etc.

    As far as the port I didn’t have anything running on 8080 so the install defaulted the port to 8080 with HTTPS on 8443 with MySQL on 3306 (more on ports in a minute).

    I think Host/Domain is one of the keys to this problem. When I couldn’t get the server to respond I just recreated an instance and tried a different Domain during the install process. I tried: internal AWS IP, External ACTUAL IP, 127.0.0.1

    Here’s what the Magento 1.9 Domain prompt looks like:

    enter image description here

    So basically that sort of brings us up to date.

    Once I finished the install, like a normal human used to using bitnami as a cloud image I assumed the server would respond at whatever the default path was at the IP address it was running on. Ie:

    BASEIPADDRESS:8080/magento

    Not the case. When I hit that the server does NOT respond, hence the question. In addition to the above I have also tried the BASEIPADDRESS, and the BASEIPADDRESS:8080

    Results checking open ports

    So since the server is not responding I figured I would check the ports.
    First I checked using netstat:

    netstat -lntu
    

    I got back:

    enter image description here

    Then I realized that netstat is now depreciated… so I went with:

    ss -lntu
    

    I got back:

    enter image description here

    (excuse the images, formatting wouldn’t work for text)

    To me it looks like 8080 (default) is open in both of those results. So why isn’t the server responding at the default location?

    #Bitnami Status = OK
    Checking the status with:
    /home/ubuntu/magento-1.9.2.4-3/ctlscript.sh status
    

    Everything looks good:

    apache already running
    mysql already running
    Memcached not running
    

    Since it says Memcached was not running, I started memcached to see if that was the issue, no it was not.

    I can access the instance via SSH and yes I am sure the IP is right. See images above.

    I also posted this to the Bitnami community but haven’t heard anything over there. Will cross populate as I get ideas.

    #36902

    Anonymous

    Accepted AnswerAnswer

    So this ended up being PRIMARILY due to not running the Bitnami stack installer as root / sudo:

    sudo /home/ubuntu/bitnami-magento-1.9.2.4-3-linux-x64-installer.run
    

    Why Install with Sudo on AWS/Lightsail?

    So the reason you need to install as sudo has to do with the fact that when run as the normal user (ie. not root) the installer defaults to port 8080 which is NOT open on aws by default. To complicate matters further you may not be able to get things running properly even if you manually swap to port 80 AFTER you run the installer.

    To avoid a scenario where port 80 requires root access to utilize I just re-created my instance and ran the installer as root with the above command.

    Host Setting

    During install I selected the public IP for the “Host” prompt and everything worked as I thought it might (straight out of the box).

    Thanks to Javier Salermon who put me on the right track and the devs at Bitnami for cueing me into the fact that 8080 is not open by default.

    Source: https://stackoverflow.com/questions/47934749/apache2-not-responding-bitnami-magento-install-legacy
    Author: Necevil
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.